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Excel 2007 Cheat Sheet
Preston Gralla and Richard Ericson

August 02, 2007 (Computerworld) If you're a full-time spreadsheet jockey, or just a casual
number-cruncher, you've come to know and either love or hate Excel's interface. Well, your world just 
changed. Throw away almost everything you know about Excel's look and feel. Microsoft Corp. made some 
very dramatic changes in Excel 2007.

The good news is that you should welcome most of the changes, because they make it easier to get at all of
Excel's power. The bad news is that you're going to have to learn how to use the application again.

That's where we come in. We'll give you a guided tour of the new interface, show you what's new and what's
the same, and offer tips and tricks for getting the most out of Excel 2007.
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So come along with us, and you'll find yourself creating charts and crunching numbers in no time at all.
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Get the lay of the land

The Excel 2007 interface represents possibly the biggest change Microsoft has made to the look and feel of 
the program and to how you get at its myriad features. No matter what you do -- from opening files or adding
formulas to creating charts or even just using a menu -- you'll find things have changed.

Here's a quick guided tour to the Excel 2007 interface:
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The Excel 2007 interface. (Click for larger 
view.)

1. The Microsoft Office button. The big button on the upper left-hand corner of the screen 
replaces the old File menu from previous versions of Excel. You'll find familiar features for opening 
files, saving files, printing files and so on, but there's a lot more here as well, as you'll discover later 
in this guide.

2. The Quick Access tool bar. Just to the right of the Office button is the
Quick Access tool bar, with buttons for using Excel’s most common features,
including Save, Undo, Redo, Sort, Print Preview and more, but you can add
and remove buttons for any functions you please. More on that later.

3. The Ribbon. Love it or hate it, the Ribbon is the main way you'll work with Excel. Instead of old-style 
menus, in which menus have submenus, submenus have sub-submenus and so on, the Ribbon groups 
small icons for common tasks together in tabs on a big, well, ribbon. So, for example, when you click the 
Insert tab, the Ribbon appears with buttons for items that you can insert into a spreadsheet, such as charts, 
tables, pivot tables, clip art or a hyperlink.

If you've spent years getting to know Excel's old interface, you'll likely be frustrated at having to learn a 
whole new interface. But even if you hate the Ribbon initially, it can be your friend; check out the section 
Learn to love the Ribbon for details.

4. The Scrollbar. This is largely unchanged from previous versions of Excel; use it to scroll up and 
down. There are a couple of minor changes. At the top, there's a double arrow that when clicked upon, 
expands the area at the top of the worksheet that displays the contents of the current cell. Just below 
the double arrow is a tiny button that looks like a minus sign that lets you split your screen in two.

5. The View tool bar. There is now a View tool bar at the bottom right of the screen that lets you 
choose between Normal, Page Layout and Page Break Preview -- a view that will show you how your 
spreadsheet will look when it prints. There's also a slider that lets you zoom in or out of your document.

Learn to love the Ribbon

At first, the Ribbon may be offputting. But the truth is, once you learn to use it, you'll find that it's far easier to
use than the old Excel interface. It does take some getting used to, though.

The Ribbon. (Click for larger view.)

The Ribbon, by default, is divided into seven tabs, with an optional eighth one (Developer) that you can 
display by clicking the Office button and choosing Excel Options > Popular > Show Developer tab in the 
Ribbon.

Here's a rundown of the tabs and what each one does:

Home: This contains commonly used Excel features, such as inserting formulas, formatting tables, rows, 
cells and text, and sorting and filtering.
Insert: As you might guess, this one handles anything you might want to insert into a document, such as 
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The Chart Tools -- Design, Layout and Format tabs appear only when you 
need them. (Click for larger view.)

charts, pivot tables, tables, pictures, clip art, text, WordArt ... well, you get the idea.
Page layout: Here's where you'll change margins, page size and orientation, define your print area, set 
page breaks, specify which rows and columns will print on each page and so on.
Formulas: If you're a spreadsheet jockey, you'll be spending a lot of time on this tab. As the name says, it's
where you'll go to insert and work with formulas. It organizes all of Excel's formulas into categories, such as
Financial, Logical, Math & Trig, and so on, so they're all within easy reach. And it also gives you quick 
access to useful formula-checking features, such as error-checking and the ability to trace precedents and 
dependents.
Data: Whatever you need to do with data, you'll find it here. For example, you can use this tab to import 
data from a wide variety of sources, including the Web, Access, SQL Server and so on. You'll also be able 
to filter and sort data, validate your data, group and ungroup data, and perform data analysis, among other 
features.
Review: Need to check spelling and grammar, look up a word in a thesaurus, work in markup mode, review
other people's markups or compare documents? This is the tab for you. It also lets you protect worksheets 
and workbooks, and share workbooks.
View: Here's where to go when you want to change the view in any way, including displaying or turning off 
gridlines and the formula bar, zooming in and out, splitting and hiding panes, and so on.
Developer: If you write code or create forms and applications for Excel, this is your tab. It also includes 
macro handling, so power users might also want to visit here every once in a while.

Each tab along the Ribbon is organized to make it easy to get your work done. As you can see below, each 
tab is organized into a series of groups that contain related commands for getting something done -- in our 
example, handling fonts.

Inside each group is a set of what Microsoft calls command buttons, which carry out commands, display 
menus and so on. In the example, the featured command button changes the font size.

There's also a small diagonal arrow in the bottom right corner of some groups that Microsoft calls a dialog 
box launcher. Click it to display more options related to the group.

Ribbon organization.

All that seems simple enough ... so it's time to throw a curveball at you. The Ribbon is context-sensitive, 
changing according to what you're doing. Depending on the task you're engaged in, it sometimes adds more
tabs and subtabs.

For example, when you insert
and highlight a chart, several 
entirely new tabs appear: 
Design, Layout and Format, 
with a Chart Tools supertitle on 
top, as you can see in the 
image to the left.

Other "now you see them, now 
you don't" tabs include Picture 
Tools, Table Tools and 
SmartArt Tools -- all of which 
appear in response to various 
actions you take in Excel.
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The Office button and Quick Access tool bar: Your new best friends

There are two more new Excel tools that you'll want to get to know -- the Office button and the Quick Access 
tool bar. Think of the Office button as a greatly expanded File menu from the Excel 2003 days -- the File 
menu on steroids. As you can see in the figure below, it's where to go for the various Open, Save, New, Print
and related options and also includes a list of all your recently opened files.

Clicking the Office button reveals everything 
the File menu used to, and more. (Click for 
larger view.)

But there are three particularly noteworthy new features here as well -- Prepare, Publish and Convert. 
Convert lets you convert documents saved in older formats to the new Microsoft Office Open XML format, 
which is the new Office standard. For Excel, the extension is .xlsx. Publish does exactly what it says; it gives 
options for publishing a document. If your company uses a document management server or SharePoint, 
you can publish it there.

Use Prepare when you've finished your worksheet and are ready to share it with others. There are plenty of 
great options here, such as marking a document as final; encrypting the document; inspecting it for hidden 
metadata and information you'd prefer remain private; and adding a digital signature. Because Excel 2007 
isn't yet widely deployed, a particularly useful feature here is running the Compatibility Checker, which will let
you know whether the worksheet contains features not supported by earlier Excel versions.

For those who like to fiddle with the Excel interface and how it works, the Excel Options button, located at 
the bottom of the Office button's box, lets you customize Excel in many ways, including how you work with 
formulas, and rules for error-checking worksheets. It has many of the features that you accessed via Tools >
Options in previous versions of Excel, plus more. It's far better organized and easier to use than Tools > 
Options was.

Even those who can't stand the Excel makeover and the Ribbon will find at
least one thing to cheer about -- the Quick Access tool bar. This nifty little tool 
seems innocuous enough, but spend some time with it and you'll see it's one of
the best additions to the new interface.

The three buttons on the left -- Save, Undo and Redo -- aren't particularly noteworthy, but the small icon to 
the right that looks like a small chart -- the Quick Layout button -- is exceedingly useful. Highlight a chart, 
click the button and a selection of premade chart layouts appear. Click the one you want, and it will 
immediately be applied to the chart.

Probably the most helpful customization for Excel 2007 is to add buttons the Quick Access tool bar, and 
there are several ways to do so. Directly to the right of the Quick Layout button, the nearly invisible Down 
arrow is the key to the Quick Access tool bar. Click it and you'll be able to add and remove tool bar buttons 
for a preset list of about 10 commands.

To add buttons for additional commands, select More Commands from this list. The screen below appears. 
(You can also get to this screen by clicking the Office button and choosing Excel Options and then 
Customize.)

Choose a command from the left-hand side of the
screen that you want to add to the Quick Access 
tool bar and click Add. You can change the order 
of the buttons by highlighting a button on the right 
side of the screen and using the Up and Down 
arrows to move it.
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The list of commands you see on the left may seem somewhat limited at first. That's because Excel is 
showing you only the most popular commands. There are plenty of others you can add. Click the drop-down 
menu under "Choose commands from" at the top of the screen, and you'll see other lists of commands -- All 
Commands, Home Tab and so on. Select any option, and there will be plenty of commands you can add.

Finally, there's an even easier way to add a command. Right-click any object on the Ribbon and choose 
"Add to Quick Access tool bar." You can add not only individual commands in this way, but also entire 
groups -- for example, the Cell Styles group.

Once you've got the Quick Access tool bar customized to your liking, you will hardly ever have to use the 
Ribbon.
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Six tips for working with Excel 2007

If you're a longtime Excel user, you no doubt have accumulated a set of shortcuts and customizations. Many
of those have gone away under Excel 2007. But fear not, because there are plenty of ways for you to bend 
Excel 2007 to your will. Here are some tips to get you started.

1. Turn off the Ribbon.
Here's what may be the best tip you'll ever come across for Excel 2007 -- how to turn off the Ribbon. Doing 
this will get you back plenty of screen real estate, as you can see in the screenshot below.

It's easy to make the Ribbon disappear and 
reappear. (Click for larger view.)

The Ribbon will still be available when you want it -- all you need to do is click on the appropriate menu 
(Home, Insert, Page Layout and so on) and it appears. It then discreetly goes away when you are no longer 
using it.

There are several ways to turn off the Ribbon:

Click the Down arrow to the right of the Quick Access tool bar button and select Minimize the Ribbon.
Press Ctrl-F1. (Press Ctrl-F1 to make it appear again.)
Double-click the current tab above the Ribbon.

2. Get your old Excel 2003 tool bars back.
Say you've given the Ribbon a fair shake and you just can't stand it. Although Microsoft doesn't provide a 
way to get the old Excel 2003 interface back, a couple of third-party tools, Classic Menu and 

ToolbarToggle, do. See Hands on: Show Office 2007 who's the boss for details.

3. Customize the Ribbon.
Maybe you mostly like the Ribbon, but some of the commands aren't located where you'd like them to be. 
Another third-party program called RibbonCustomizer Pro lets you create new Ribbon tabs or customize 
existing ones the way you like them.

It's a powerful way to take advantage of the Ribbon's interface while asserting control over what commands 
appear where. Again, see Hands on: Show Office 2007 who's the boss for more information.

4. Use keyboard shortcuts.
If you're a fan of Excel 2003's keyboard shortcuts, take heart -- most of them still work in 2007. So keep 
using them.

You can also use a clever set of keyboard shortcuts for working with the Ribbon. Press the Alt key and a tiny
letter or number icon appears on the menu for each tab -- for example, the letter H for the Home tab. (See 
the image below.) Now press that letter on your keyboard, and you'll display that tab or menu item. When 
the tab appears, there will be letters and numbers for most options on the tab as well.
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Using the Alt key helps you master the Ribbon.

Once you've started to learn these shortcuts, you'll naturally begin using key combinations. So instead of 
pressing Alt then H to display the home tab, you can press Alt-H together. The following table shows the 
most useful Alt key combinations in Excel 2007.

Excel 2007 Alt key combinations

Key combination Function

Alt-F Office button

Alt-H Home tab

Alt-N Insert tab

Alt-P Page Layout tab

Alt-M Formulas tab

Alt-A Data tab

Alt-R Review tab

Alt-W View tab

Alt-L Developer tab
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5. Use macros.
At first glance, macros -- ingenious shortcuts you can create for performing repetitive tasks -- seem to have 
been banished from Excel 2007. But they're still there; display the Developer tab, and you'll find them in all 
their glory. In fact, the Developer tool bar puts the macro tools at easier reach than they were in previous 
versions of Excel.

You'll find everything you want in the Code group on the Developer tab. Record a macro by clicking the 
Record Macro button, manage your macros by clicking the Macros button and configure security for macros 
by clicking the Macro Security button.

All your macro controls are in the Code group 
on the Developer tab.

Any macros you created in previous versions of Excel should work fine in Excel 2007. See Microsoft's Office 
Online site for more information about working with macros in Excel 2007.

6. Find your old friends.

In Excel 2007, no features or functions are where they used to be. But it's easy to find them. Use our Excel 
2007 quick reference charts for an extensive list of where to find your old friends.
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Conditional formatting rules are easy to adjust. (Click for larger view.)

New features in Excel 2007

In Excel 2007, more is truly better. Microsoft has increased the number of columns per spreadsheet (and per
PivotTable) to 16,384 (up from 256) and the number of rows to 1,048,576 (up from 65,536). Other limits 
have been also expanded: Text cells can now contain more than 32,000 characters (up from 255).

Chances are you'll never reach other new limits: PivotTables can manipulate more than 16,000 fields (up 
from an already generous 255), and formulas can now refer to up to 8,000 cells (memory permitting), so it's 
fortunate that Excel 2007 lets you drag the corner of the formula bar to expand it.

Excel 2007's memory manager can handle 2GB (double the amount in Excel 2003), so calculations execute 
faster. The new version also takes advantage of dual-core processors and multithreaded chip sets, so if 
you're lucky enough to be running it on a machine with either feature, expect a noticeable speed boost.

New visualization tools
Charts and graphs now support 16 million colors, and improved color support is evident throughout this 
version, especially in several new visual tools for highlighting data. For example, in Excel 2007 you can use 
conditional formatting to set the background color of a cell or use a colored bar (called a data bar) -- the 
length corresponds to the cell's value.

You can also add icons to cells based on their value, giving your worksheet a dashboard-like quality. For 
example, assigning traffic-light icons to a range of cells is a snap, and Excel's built-in logic assigns colored 
circles based on the value of the cell: green for the highest third, yellow for the middle third and red for the 
bottom third.

You can add colored bars to indicate the value in a cell (left) or apply a three-icon set to indicate 
which third data falls into (right); a red traffic light indicates the cell is in the lowest third of all 
values in the range.

Similarly, a four- or five-icon set (such as set of vertical bars similar to what your cell phone uses to indicate 
signal strength) displays icons based on which quartile or quintile the value falls into.

In all cases, you
can control the 
ranges for each 
icon in the set -- 
allowing you, for 
instance, to use a 
green traffic light to 
indicate only the 
highest 10% of 
values. 
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Better sorting and filtering
Sorting data -- previously limited to three levels -- has been expanded to 64 levels. Best of all, while you can 
still sort data based on values (to sort a date column chronologically, for instance), you can also sort by font,
color or icon used with conditional formatting. Thus, you can display all your green traffic lit cells together, 
followed by the yellow lights, then the red.



Excel 2007 Cheat Sheet http://www.computerworld.com/action/article.do?command=printArticle...

8 of 11 10/3/2007 2:34 PM

Choose a style from the gallery and see it applied to your 
selection. (Click for larger view.)

You can sort by value or the icon used in 
conditional formatting. (Click for larger view.)

Other visualization tools eliminate the need for complicated macros or formulas. New conditional formatting 
options let you highlight duplicates, unique values, the top/bottom 10%, values above or below the average, 
cells less than or greater than a specified value, or cells within a range (highlighting cells containing values 
between 1 and 10, for example).

If you don't need to see all values, the vastly improved Filter feature puts check boxes (for up to 1,000 
values) in a pull-down list, allowing you to easily pick multiple values to display. Likewise, the new Remove 
Duplicates feature hides rows based on the duplicate values in columns you specify.

The new Filter feature offers check boxes 
to let you pick which rows you want to 
see.

Working with PivotTables
Among the notable improvements in Excel are tools to make existing features easier to use. Take 
PivotTables, for example. (For the uninitiated, PivotTables allow you to view your data differently -- think 
"slice and dice." For example, you can summarize sales by agent by month or, with a simple drag-and-drop 
motion, summarize sales by month and within month by agent.)

In Excel 2007, you still set up PivotTables using a wizard, which is slightly changed from Excel 2003. 
However, once you have a PivotTable defined, manipulating it is considerably easier.

Instead of dragging and dropping elements within the table itself, you can use the wizard to make choices -- 
checking boxes to select which fields to display or choose sorting options, for example. Excel 2007 makes it 
easier to switch columns and rows, filter values, and use or hide field names. In addition, conditional 
formatting (those data bars or traffic lights we mentioned) can be applied to cells displayed in PivotTables.

PivotTables are easier to use, thanks to a new PivotTable panel. (Click for larger view.)

Styles and Themes

One of the promises of the Ribbon interface,
according to Microsoft, is that some features are 
more obvious and usable. That's certainly true of 
Styles, a formatting tool from previous versions of
Excel that is now available using a "gallery" 
interface introduced in Office 2007.

You can quickly apply a collection of settings, 
from the font used to the background color and 
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border style to cells, tables and PivotTables. As you mouse over the choices, Excel 2007 applies each style 
to your selection so you can preview the effect without making the change permanent.
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One particularly noteworthy improvement to formatting is how Styles now respond to changes within your 
worksheet. In Excel 2003, you could apply a "green bar" effect so that the background color in rows 
alternated between green and white. However, once you added a row, the pattern was interrupted, and you 
needed to reapply the AutoFormat, a clumsy and awkward procedure.

In Excel 2007, that same pattern is adjusted whenever you add one or more rows. (Styles are equally smart 
when you add columns, for patterns that alternate between columns.) Styles will even adjust when you filter 
or hide rows or columns.

Themes, new to Office 2007, are style collections that include a color scheme, font, fill effects and more. 
Shared by several Office 2007 applications, themes can be applied to charts, tables and PivotTables in 
Excel, giving your work a consistent look and feel. That's especially useful when you're creating a chart that 
you want to copy to PowerPoint or Word.

A table with the Equity theme applied.

To use Themes, select the Page Layout tab and click the Themes button to choose a new theme. You can 
also customize any theme or create new ones. One important caveat: Be aware that Themes only work if 
you're using Word's new Office XML format; they won't work on old-style .xls files.

The Ribbon interface also makes it more enjoyable to work with charts. Excel's charts have a whole new 
look, thanks to the new graphics engine in all Office 2007 applications. The layouts use different color 
palettes and fonts, but the important difference is the ability to more easily apply graphical effects, such as 
bevels and shadows, to individual elements (such as columns or pie slices).

With Excel's new charting engine, you can 
control everything about charts, from shadows 
to the amount of rounding on the corners of 
bars and columns.

The Ribbon interface has a Chart Tools group (with tabs for Design, Layout and Format) to put more 
charting options at your fingertips and eliminate most of the right-clicking you had to do to adjust charts in 
previous versions: switching rows and columns, controlling gridlines and axes, and adding trend lines.
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Working with a Total row. (Click for larger view.)

Table tools
Excel's new table features make it less likely you'll have inconsistent formulas. Once you identify a 
contiguous range of cells as a table, Excel provides calculated columns. For example, if you add a column to
the right of your table and enter a formula in any row, the formula will be copied to all cells in that new 
column, saving the time of executing a copy/paste command.

Even smarter, add a row and Excel is sure to include it in a total on the bottom row. (In previous versions of 
Excel, adding a row at the top or bottom of a range meant you risked omitting cells in that row from the sum 
formula.)

Furthermore, options on the
Table Tools Design 
context-sensitive tab let you 
toggle the formatting of the first 
column or the first row. One 
click and you can add a Total 
row (though Excel lacks a 
similar command to add a Total 
column), then change what 
each column in that row computes (total, average, minimum and so on).

In addition, as you scroll down through a lengthy table, Excel replaces the column headings (the gray boxes 
with A/B/C above the columns) with values from the table's header row -- a subtle improvement, to be sure, 
but it's a more efficient technique than having to freeze rows to see column headings.

Finally, the new Table Gallery makes it easy to select and apply a sophisticated look.
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Other changes
There are dozens of other small changes In Excel 2007. Among the 51 new functions are some to fetch data
from OLAP cubes, calculate Bessel functions (for engineers), convert numbers (decimal to binary, hex to 
octal and so on) and work with complex numbers (calculating the square root or sine of a complex number, 
for example). Two new functions, SUMIFS and AVERAGEIFS, let you choose cells that meet multiple 
conditions without having to use nested functions. Speaking of nesting, should you need it, the number of 
nesting levels has increased, from seven in Excel 2003 to 64.

The new Name Manager helps you organize and manage your named ranges. Other changes keep Excel's 
user interface consistent with Word and PowerPoint. SmartArt is shared across Office 2007 applications, 
and as with Word, it's now easy to save a document to PDF or XPS format, or to a SharePoint library directly
from Excel.

Saving a document in PDF or XPS format is 
now possible through the Office button.

If you use PowerPoint to build charts, you'll find that its old graphics tool (MSGraph) has been replaced by 
Excel's charting and worksheet engine, a long overdue improvement.

Staying compatible
You'll have to deal with four new XML-based file formats in Excel 2007 -- .xlsx for standard worksheets, 
.xlsm for those with macros, plus .xltx and .xltm for templates. Like Word 2007, Excel 2007 offers a 
compatibility checker and tells you if your workbook contains features that previous versions of Excel won't 
support. Choose Office button > Prepare > Run Compatibility Checker to launch it.

If you're sharing documents, you'll probably want to save them in Excel 2003 format to maintain compatibility
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with other users -- at least until the new 2007 file format becomes the standard or you know your recipient 
has the free patch that lets Office 2003 users read and work with 2007 files.

To set Excel 2007 to save to the 2003 format by default, click on the Office button and then the Excel 
Options button. In the left panel of the screen that appears, click Save, then locate the "Save workbooks" 
area on the right. From the "Save files in this format" drop-down list, choose Excel 97-2003 Workbook and 
click OK.

Setting the default Save format. (Click for 
larger view.)

As we've shown you, Excel 2007 is chock full of new features, some of which may initially drive you crazy. 
But armed with our cheat sheet and a little elbow grease, you'll be up and running -- and quite possibly 
loving the new Excel -- in no time.
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